Harvestor Management Problems

Discuss any general aspect of crafting in this forum.

Moderators: Crafting Forum Moderators, Forum Moderator

Novice Crafter
Posts: 3
Joined: Sun May 02, 2010 6:20 pm

Harvestor Management Problems

Post by Necrose » Sun May 02, 2010 6:30 pm

Hi all. Totally new crafter here, hoping for an education. I've dropped a couple of wind generators in-game, but cannot manage them now that they are down. It took me the longest time to figure out I needed to target the generator then right-click on the name of the generator to bring up the menu (i.e. clicking or right-clicking on the structure itself did nothing). The "lock window" and "examine" options work, but the "Structure management" option does not seem to be working properly as far as I can figure. It brings up the sub-menu ("Structure Management", "Destroy Structure", "Status", "Pay Maintenance", "Set Name" and "Operate Machinery"). But the only one of those sub-options that does anything is "Structure Management", which gives basic info (like the owner, condition, maintenance rate, maintenance pool, etc.). When I click on any of the other options (like Pay Maintenance, Operate Machinery or Destroy Structure), absolutely nothing happens. So I can't drop in any maintenance, and I can't take down the generator now that it's up. I'd appreciate anyone telling me what I'm doing wrong, as I'm watching my generators degrade before my very eyes and there's nothing I can do about it. Thanks in advance for any help.

Forum Moderator
Posts: 4817
Joined: Mon May 14, 2007 6:55 am
Location: Stockholm, SE

Re: Harvestor Management Problems

Post by Zimoon » Sun May 02, 2010 8:44 pm

Hmm, this can be of several reasons.

First, only the owner of the harvester can operate it, hence, if you try this with some other character at the same account or another account it won't work. However, this seems not to be the case since you really see these other options.

Second, are you sure that the targeted harvester is the one you think? The targeting system is not really kind always, so, have a look at the little target window and ensure the distance is reasonable. It may be that you still have a distant harvester active, not the one you are facing. Sometimes it helps to zoom back the camera as far as possible and you stay about 5 meters from the thing, that usually shows which structure you really have targeted.

Third, are you playing at a trial account? I have a vague memory about issues with that and I think it is that you are not supposed to be able to put down any structures until you activate the account. But I admit I am not 100% here.

Fourth, find the Beginners Guide for Traders in this forum. In the chapter with misc hints and tips you find some chat-bat commands you can use. Still you must have the correct harvester targeted and I am 80% sure this is the real issue.

Finally, whatever it was, please tell us. It adds to our shared knowledge-base.

And now ..... welcome around, warmly welcome :mrgreen:


Novice Crafter
Posts: 3
Joined: Sun May 02, 2010 6:20 pm

Re: Harvestor Management Problems

Post by Necrose » Sun May 02, 2010 9:08 pm

Thanks for the insights. To touch on your points individually:

1. I only have one character, and he is the owner of the harvesters, so I don't think that is the issue.

2. I understand the targeting can be spotty, but I'm pretty sure I'm targeting the right one. It says the distance is 0m when I'm standing right next to it, plus I tried your trick and came up with the same results. Per your fourth point, below, I tried some of the /commands and was able to add maintenance and try to destroy the structures - so that much worked - but that was all I could do through those commands. So, overall, I think I'm targeting the right structures - it's just that nothing happens when I try to use the pulldown menu.

3. Regarding trial account status, you're right - I was a trial account, but was not permitted to place structures as a trial account. So I switched to a subscription, and was able to place the harvesters - I just can't manage them after I placed them. Is there a "double secret subscription" I need to be a part of to do that? :lol:

4. See #2, above.

Furthermore, as a test, I went to a different area and dropped an ore harvester (as opposed to the wind generators that initially triggered the problem) just to see if I could get that one harvester to work. No luck - I had exactly the same problems. That is now rotting away in the swamps of Naboo, too. It's more than a little frustrating - I had heard good things about crafting and the player economy in SWG, and that's what I wanted to get involved in. I'll keep poking around, but I'm not sure what else to do. If you or anyone else has any suggestions, they would be much appreciated. Thanks again for your thoughts!

User avatar
Architect & Shipwright Forum Moderator
Posts: 1226
Joined: Mon Mar 26, 2007 9:45 pm
Location: Central Oregon

Re: Harvestor Management Problems

Post by Savacc » Sun May 02, 2010 9:37 pm

Hmmm, like Z, my problems with getting harvesters to work always came back to targeting. Try moving around, zoom in, zoom out, look down - anything to target just the harvester.

Your statement about "rightclicking" to get the radial menu, suggests you have remapped your keyboard commands. The default way to bring up the radial menu of the target is the ~ key (just above Tab). You might want to recheck your keyboard commands to see exactly what you have assigned to "right mouse button"

Those are the only things I can think of for you. If that dosent work, get an ingame GM to help. You could be "bugged" in that some parts of the game read you as a "subscribed" char and some parts as still a "trial" char.

One more thought - Can you "Name" the harvester, either with the radial menu or /name command? That could help you with targeting.

Intermediate Crafter
Posts: 169
Joined: Thu Feb 19, 2009 8:06 am
Location: Stockholm, Sweden

Re: Harvestor Management Problems

Post by Swedishoyster » Sun May 02, 2010 9:43 pm

Try to switch your keymap to "Star Wars Galaxies Modern"
it's really much easier and you can right click to interact with stuff, it might solve your problem.
Sork Inc. Perdition, Dantooine
Hunterella, Architect/Armorsmith - Sorkella, Ranger/Riflewoman
Snufsan, Tailor/Chef/x - Healerella, Doctor
Bimborella, Swordswoman/Medic - Sniperella, Rifle/BE

Novice Crafter
Posts: 3
Joined: Sun May 02, 2010 6:20 pm

Re: Harvestor Management Problems

Post by Necrose » Sun May 02, 2010 11:00 pm


That did the trick. Not sure why I could see the choices but they didn't work under the other settings, but once I made that change everything worked as it should. My first little wind and ore harvesters are up and running. Thanks to everyone for your help - I greatly appreciate it!

Novice Crafter
Posts: 21
Joined: Fri Jun 20, 2008 5:29 am

Re: Harvestor Management Problems

Post by Bulba » Mon May 03, 2010 11:45 pm

The radial menu must not overlap any other harvestor except the one you want to interact with. If you open the radial menu on harv A, and click on an option while the menu is overlapping harv B, the game will try to apply the action to harv B.

Thank the NGE hack-job of an UI. One of the SOE devs stumbled across this problem last year and was surprised to see it, despite my (and others) many bug reports. It still remains bugged.

Sorry if thats a bit negative, but it really annoys me :)


Who is online

Users browsing this forum: Magpie [Bot] and 5 guests