SWGAide v0.7.33 Beta

Moderator: Forum Moderator

User avatar
Zimoon
Forum Moderator
Posts: 4817
Joined: Mon May 14, 2007 6:55 am
Location: Stockholm, SE
Contact:

Re: SWGAide v0.6.10 BETA

Post by Zimoon » Mon Mar 24, 2008 8:08 am

SpaceyDaFrog wrote:And something I just found out while updating some ISDroid reports...

When you have an ISDroid mail older than 4 hours, it pops up a window asking if you want to either Continue (with the old report still in play) or delete the old report, if you click on the X to close the window it takes that response as a Delete.

Should it be that way, or should closing the window default as a Continue? I would have assumed it should continue instead of delete...
I will look into this, I believe this is from Delete is the default option. Closing with X I would rather bail out, because how can anybody know what you mean when you don't choose a button? To me it is not really obvious in that case.

/Zimoon

User avatar
Zimoon
Forum Moderator
Posts: 4817
Joined: Mon May 14, 2007 6:55 am
Location: Stockholm, SE
Contact:

Re: SWGAide v0.6.10 BETA

Post by Zimoon » Mon Mar 24, 2008 10:37 am

Zimoon wrote:
SpaceyDaFrog wrote:And something I just found out while updating some ISDroid reports...

When you have an ISDroid mail older than 4 hours, it pops up a window asking if you want to either Continue (with the old report still in play) or delete the old report, if you click on the X to close the window it takes that response as a Delete.

Should it be that way, or should closing the window default as a Continue? I would have assumed it should continue instead of delete...
I will look into this, I believe this is from Delete is the default option. Closing with X I would rather bail out, because how can anybody know what you mean when you don't choose a button? To me it is not really obvious in that case.
Clicking the X used the default button, which is Delete, as I thought. I have changed the behavior to do nothing at all, really nothing. This will be included in next update. For now the workaround is to use the buttons and if so, go to Trash and select the mails you want to retrieve, right-click them and choose Move ...

/Zimoon

User avatar
Zimoon
Forum Moderator
Posts: 4817
Joined: Mon May 14, 2007 6:55 am
Location: Stockholm, SE
Contact:

Re: SWGAide v0.6.11 BETA

Post by Zimoon » Mon Mar 24, 2008 3:48 pm

SWGAide v0.6.11 Beta has just been uploaded.

Fixes the issue with reports that got deleted when discarding the "old reports" dialog. Now nothing will happen, nothing whatsoever.

Resources wrongly marked as available at some planet it is not really found at will no longer cause all resources to be marked as depleted. That is as long as any other report contains a trace of that resource, otherwise SWGAide cannot know. In other words, if you always send out ISDroids to the ten core planets everything will work as expected. No dialog telling about the wrongly submitted resource is raised though.

Not stations, galaxies, and/or characters that are manually deleted from the harddisk will now also be removed from the GUI view. However, SWGAide itself will not delete anything from the harddisk.

Started the rework of the error handling. Now errors taking place during the automatic resource download from SWGCraft as well as the initial preparation and parsing of the ISDroid reports will raise a very simple and plain dialog about it. Text will be written to the general log file. All initial actions are aborted and you may try again in a minute or so, if possible.

Please, take the moment and send the log file to me at the email address read in the file itself. That is since I will make the dialog more useful and descriptive over time, now it just reports that something bad happened.

Download at link in my signature, as usual :)

Kindly

/Zimoon

User avatar
Rommel
Intermediate Crafter
Posts: 177
Joined: Wed Jun 27, 2007 8:14 pm
Location: Atlanta, GA, USA

Re: SWGAide v0.6.10 BETA

Post by Rommel » Mon Mar 24, 2008 7:11 pm

Zimoon wrote:
Rommel wrote:
SpaceyDaFrog wrote:How about a new button for the ISDroid support area.
Clear "res.txt"
Obviously, it will clear the res file out. Useful as a last minute double-check before writing a new res.txt file. Not an important idea, but an easy one. hehe
I agree.
Ahem, there is an option that, if selected, should do exactly that when uploading finished error free. It does not work for me and have not looked into that thingie yet. But of course, a button would be better either way.
/Zimoon
Yeah, that option doesn't work for me either. I must be having errors and not knowing about it or something.

User avatar
Zimoon
Forum Moderator
Posts: 4817
Joined: Mon May 14, 2007 6:55 am
Location: Stockholm, SE
Contact:

Re: SWGAide v0.6.11 BETA

Post by Zimoon » Tue Mar 25, 2008 8:18 pm

SWGAide v0.6.12 is uploaded.

I am sorry but an "i" had disappeared from Oridium Intrusive Ore in the XML file that makes for the resource classes in SWGAide. I found the "i" with Rommel's help and have now glued it in its proper place again.

/Zimoon

User avatar
Rommel
Intermediate Crafter
Posts: 177
Joined: Wed Jun 27, 2007 8:14 pm
Location: Atlanta, GA, USA

Re: SWGAide v0.6.12 BETA

Post by Rommel » Tue Mar 25, 2008 10:12 pm

My bad :P

If you aren't gonna do anything with that extra space to the right of the submit buttons on the ISDroid page can the box's be elongated so less left to right scrolling has to be done with long names and such that appear in them?

I don't know if it's possible but maybe make them sized based on a percentage this way they are always the right size no matter the users screen resolution.

Here is a little mock up I did...
Image
I just split up the total size of the bottom area in two and sized that way, I probably should have removed those horizontal scroll bars since there isn't a resource name long enough.

User avatar
Zimoon
Forum Moderator
Posts: 4817
Joined: Mon May 14, 2007 6:55 am
Location: Stockholm, SE
Contact:

Re: SWGAide v0.6.12 BETA

Post by Zimoon » Wed Mar 26, 2008 7:50 am

Rommel wrote:My bad :P

If you aren't gonna do anything with that extra space to the right of the submit buttons on the ISDroid page can the box's be elongated so less left to right scrolling has to be done with long names and such that appear in them? ...
I already have some code there for this but I didn't get it right and have had no time for it. But this is definitely on my backlog.

And thanks for your help with the XML earlier on, how could we know that this "i" would take the opportunity to run away?? ;)

/Z

Tharek Tolemac
Intermediate Crafter
Posts: 139
Joined: Sun Jun 03, 2007 8:48 am

Re: SWGAide v0.6.12 BETA

Post by Tharek Tolemac » Wed Mar 26, 2008 8:25 pm

Hey there.
I wondered lately if the mailexport to SWGAide is bugged, because I had gaps between the number of items that should be in a vendor according to storage and sold items and what was inside.

I just tried it with 5 Sale Mails for Coarse Fish and after the export, in SWGAide it said I sold 4 items.

After a manual check, I found out that the vendor really sold 5 items.

User avatar
Zimoon
Forum Moderator
Posts: 4817
Joined: Mon May 14, 2007 6:55 am
Location: Stockholm, SE
Contact:

Re: SWGAide v0.6.12 BETA

Post by Zimoon » Wed Mar 26, 2008 8:58 pm

Were they properly saved to harddisk before you eventually deleted them in game??
Are they read somewhere else in SWGAide, such as at the ordinary mail list?
Are they left in the SWG\profiles\your_account\galaxy\mail_character\ folder?

I have not seen any missing mails whatsoever, but that is no sign it couldn't happen weird things. I assume you run SWGAide at the same computer you run SWG at, no fancy networked file system involved? Then it's almost impossible to "loose" a mail, they are just moved using Windows' file system features.

But I could imagine SWGAide could miss some mail if it has some unusual formatting, but then I would really want to inspect such a mail so I could tweak SWGAide to recognize them in the future. Please browse your SWG\profiles folders and see if they remain there. Try to see if it is found in a wrong mail folder SWGAide.

/Zimoon

Tharek Tolemac
Intermediate Crafter
Posts: 139
Joined: Sun Jun 03, 2007 8:48 am

Re: SWGAide v0.6.12 BETA

Post by Tharek Tolemac » Wed Mar 26, 2008 10:06 pm

Wierd. I found it now. Maybe there was a strange sorting or something.

Will follow that.

Edra
Novice Crafter
Posts: 44
Joined: Mon Dec 31, 2007 5:48 pm

Re: SWGAide v0.6.12 BETA

Post by Edra » Fri Mar 28, 2008 8:42 pm

When looking at the trade tab/statistics. The vendor list on the right side is showing me a negative number. Also would help if you allowed those column to slide a bit more, it wont go to the left any further.

Image

User avatar
Zimoon
Forum Moderator
Posts: 4817
Joined: Mon May 14, 2007 6:55 am
Location: Stockholm, SE
Contact:

Re: SWGAide v0.6.12 BETA

Post by Zimoon » Fri Mar 28, 2008 10:01 pm

I will look into it, seems as if you have sold for more than 2,147,483,648 which is the limit for regular integers in Java (much less in many other programming languages ;)). I thought I changed this not long ago, which version do you use?

EDITED: Obviously not, I had forgot two cases, will be included in next update.

/Zimoon

Aali
Novice Crafter
Posts: 2
Joined: Fri Feb 29, 2008 4:52 am

Problem with SWGAide when sending Res.txt

Post by Aali » Sat Mar 29, 2008 11:48 pm

When I try to send my res.txt using the SWGAide (.6.12) I get the following error:
"Error in line: "Oidifecee,Lokian Domesticated Corn,130,416,749,925":
Resource == null
I can't seem to find a way to attach my res.txt file. So here is a copy of the first couple lines.

Scylla / Lok / 1206825717
swgcraft_start
Oidifecee,Lokian Domesticated Corn,130,416,749,925
...
swgcraft_end
This is happening with every line in my res.txt file. The res.txt file was initially created by SWGAide and then I modified it with stats in game
suggestions?
Last edited by Sobuno on Sun Mar 30, 2008 12:41 am, edited 1 time in total.
Reason: Post merged to SWGAide topic

User avatar
Zimoon
Forum Moderator
Posts: 4817
Joined: Mon May 14, 2007 6:55 am
Location: Stockholm, SE
Contact:

Re: SWGAide v0.6.12 BETA

Post by Zimoon » Sun Mar 30, 2008 8:29 am

Welcome to SWGCraft and your first post ;)

I am sorry but cannot really tell why you have this problem. Would you mind attach the files res.txt, the SWGAide error log, and the SWGAide log to an email. My email address is simongronlund :!: gmail.com

/Zimoon

User avatar
Zimoon
Forum Moderator
Posts: 4817
Joined: Mon May 14, 2007 6:55 am
Location: Stockholm, SE
Contact:

Re: SWGAide v0.6.12 BETA

Post by Zimoon » Sun Mar 30, 2008 10:18 am

It just struck me, did you exit SWGAide and launched it again when you had filled in the res.txt? If so, that won't work, let SWGAide run in the background while you are in game and fill in the stats. It will work in some future version of SWGAide when I have added means for manual resource adding not dependent on ISDroid reports.

If that was the case I have a workaround:
1) Copy the content of the res.txt.
2) Do everything from start as usual, including "write to res.txt"
3) Replace the content of res.txt by deleting the content and paste the stuff from 1)
4) Click "submit"

Does that resolve your problem?

If not, please elaborate a bit in the email what you did.

/Zimoon

Post Reply

Who is online

Users browsing this forum: No registered users and 20 guests