Page 1 of 1

v0.0.8 run-error

Posted: Tue Aug 04, 2015 10:22 am
by Gingah
Hi again,

I downloaded the 0.0.8 release (.exe) from GitHub, but when running from scratch - ie, placed .exe in a new directory and ran - it fails to start and gives the following error: "A Java Exception has occurred." (given by Java Virtual Machine Launcher). Not quite sure what goes wrong as there is no error code.

Re: v0.0.8 run-error

Posted: Tue Aug 04, 2015 3:19 pm
by Sobuno
Is there any log file in the logs directory? Or anywhere else?

What version of Java do you have? (Run command-line prompt, type java -version)
Did you try running as admin?
What OS are you running?

Re: v0.0.8 run-error

Posted: Tue Aug 04, 2015 5:09 pm
by Gingah
It did not get as far as creating a log directory or anything else, failed before that. Java version 1.7.0_17, runtime is 1.7.0_17-b02. Tried as admin also, running Windows 7 64-bit.

Re: v0.0.8 run-error

Posted: Tue Aug 04, 2015 7:40 pm
by Sobuno
Did you try the JAR version?

Re: v0.0.8 run-error

Posted: Tue Aug 04, 2015 8:40 pm
by Gingah
I get the same error as with the exe. However the 0.0.7 jar works as well as the 0.0.7 exe.

Re: v0.0.8 run-error

Posted: Wed Aug 05, 2015 5:05 pm
by Sobuno
Gingah wrote:I get the same error as with the exe. However the 0.0.7 jar works as well as the 0.0.7 exe.
Weird, the only thing that has changed is a reinstall of my development tools, I am using the same config as before though.

Is anyone else having this problem? Or do you perhaps have a second machine to verify?

Re: v0.0.8 run-error

Posted: Thu Aug 06, 2015 9:11 am
by Gingah
I tested it now on a Windows 8.1 32-bit machine, and it ran without error. Another difference is that the SWG directory is not placed within the Program Files directory, but in the Downloads folder. Does Java keep an error log, or can it be enabled somehow? It might give some clue to why the Win7-64 machine is unable to run it.

Re: v0.0.8 run-error

Posted: Thu Aug 06, 2015 2:11 pm
by Sobuno
Gingah wrote:Another difference is that the SWG directory is not placed within the Program Files directory, but in the Downloads folder.
Do you mean the SWGAide directory or SWG directory? On initial launch, SWGAide knows nothing about the location of SWG.

Try running through command line as such: java -jar SWGAide.jar and see if any errors pop up in the command line

Re: v0.0.8 run-error

Posted: Thu Aug 06, 2015 2:57 pm
by Gingah
Oh, the SWG directory. It is copied from my laptop a time ago, and on the Win 8.1 (RT, it's a tablet) it runs from the Download folder. I ran the suggested command and got the following error:

Code: Select all

Exception in thread "main" java.lang.UnsupportedClassVersionError: swg/SWGAide : Unsupported major.minor version 52.0
        at java.lang.ClassLoader.defineClass1(Native Method)
        at java.lang.ClassLoader.defineClass(Unknown Source)
        at java.security.SecureClassLoader.defineClass(Unknown Source)
        at java.net.URLClassLoader.defineClass(Unknown Source)
        at java.net.URLClassLoader.access$100(Unknown Source)
        at java.net.URLClassLoader$1.run(Unknown Source)
        at java.net.URLClassLoader$1.run(Unknown Source)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(Unknown Source)
        at java.lang.ClassLoader.loadClass(Unknown Source)
        at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
        at java.lang.ClassLoader.loadClass(Unknown Source)
        at sun.launcher.LauncherHelper.checkAndLoadMain(Unknown Source)

Re: v0.0.8 run-error

Posted: Thu Aug 06, 2015 8:48 pm
by Sobuno
Gingah wrote:Oh, the SWG directory. It is copied from my laptop a time ago, and on the Win 8.1 (RT, it's a tablet) it runs from the Download folder. I ran the suggested command and got the following error:

Code: Select all

Exception in thread "main" java.lang.UnsupportedClassVersionError: swg/SWGAide : Unsupported major.minor version 52.0
        at java.lang.ClassLoader.defineClass1(Native Method)
        at java.lang.ClassLoader.defineClass(Unknown Source)
        at java.security.SecureClassLoader.defineClass(Unknown Source)
        at java.net.URLClassLoader.defineClass(Unknown Source)
        at java.net.URLClassLoader.access$100(Unknown Source)
        at java.net.URLClassLoader$1.run(Unknown Source)
        at java.net.URLClassLoader$1.run(Unknown Source)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(Unknown Source)
        at java.lang.ClassLoader.loadClass(Unknown Source)
        at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
        at java.lang.ClassLoader.loadClass(Unknown Source)
        at sun.launcher.LauncherHelper.checkAndLoadMain(Unknown Source)
Accidentally had Java requirement set to 1.8 it seems, and you were only running 1.7 (It is advised to update as 1.7 is no longer supported by Oracle)

I've updated the files on the download page to lower the requirement to 1.7

Re: v0.0.8 run-error

Posted: Thu Aug 06, 2015 11:35 pm
by Gingah
I figured that could be the reason, as my tablet apparently runs Java 1.8. The 0.0.8 .exe works as expected now, thank you very much for the debugging and maintaining of the program.