SWGAide for Emulators

Moderator: Forum Moderator

User avatar
Sobuno
Developer
Posts: 2589
Joined: Sun Mar 25, 2007 2:17 am
Contact:

SWGAide for Emulators

Post by Sobuno » Tue Jan 10, 2012 11:41 pm

The current version of SWGAide (0.9.8) unfortunately only supports the official servers as the list of servers is hardcoded in the source code. Zimoon has not been online for several months, and development on the project is discontinued as per the official homepage of SWGAide.

So I decided to spend a few hours today to allow players on unofficial servers to employ the usage of SWGAide in their resource gathering. I have made a new version of SWGAide (0.9.8-Sobuno) in which the list of servers has been ripped out and replaced by a new structure, allowing support for servers to dynamically be added as they appear.

Two caveats though: First, this version is NOT backwards-compatible with 0.9.8 or any other version. It is necessary to delete (or move) your SWGAide.DAT file and the backups before attempting to use this version, otherwise it will not work. Second, Internet access is required to get the list of servers, so it is recommended to have Internet access the first time you start the new version. Once the initial list has been downloaded, you will be fine; the program periodically checks if a new version of the list has been uploaded and fetches it if it has.

Oh, and one more thing: It has not been tested at all, and I offer minimal to no support for it.

User avatar
Sobuno
Developer
Posts: 2589
Joined: Sun Mar 25, 2007 2:17 am
Contact:

Re: SWGAide for Emulators

Post by Sobuno » Tue Jan 10, 2012 11:42 pm


User avatar
Monty Burns
Master Crafter
Posts: 549
Joined: Sat Mar 08, 2008 9:26 am
Location: New Zealand

Re: SWGAide for Emulators

Post by Monty Burns » Sat Jan 14, 2012 9:01 pm

Sobuno wrote:Download is here: SWGAide 0.9.8-Sobuno
Good news, I have been messing with the emu and this will probably get me to look at it more seriously.

Wieli
Novice Crafter
Posts: 23
Joined: Fri Apr 01, 2011 7:03 am

Re: SWGAide for Emulators

Post by Wieli » Sun Jan 15, 2012 12:15 am

I know that yo dont do any updates on it.

Just letting to know that i cant get it to work, cant choose directorypath that the program accepts

User avatar
Sobuno
Developer
Posts: 2589
Joined: Sun Mar 25, 2007 2:17 am
Contact:

Re: SWGAide for Emulators

Post by Sobuno » Sun Jan 15, 2012 1:05 am

Wieli wrote:I know that yo dont do any updates on it.

Just letting to know that i cant get it to work, cant choose directorypath that the program accepts
SWGAide requires that the SwgClient_r.exe file is present in the directory you choose when starting the program for the first time. As far as I am aware, that is the only requirement

Wieli
Novice Crafter
Posts: 23
Joined: Fri Apr 01, 2011 7:03 am

Re: SWGAide for Emulators

Post by Wieli » Sun Jan 15, 2012 8:24 am

hmm, well i have the file in the folder so im not sure, im no Java programmer tho so i wont be able to make a try.

User avatar
Monty Burns
Master Crafter
Posts: 549
Joined: Sat Mar 08, 2008 9:26 am
Location: New Zealand

Re: SWGAide for Emulators

Post by Monty Burns » Sun Jan 15, 2012 8:46 am

I can get it to run but I cant get it to find my profiles the account name is there but no characters to select.

It looks like the emulator stores character profiles differently.

User avatar
Sobuno
Developer
Posts: 2589
Joined: Sun Mar 25, 2007 2:17 am
Contact:

Re: SWGAide for Emulators

Post by Sobuno » Sun Jan 15, 2012 1:08 pm

Ok, I'll dig out my SWG CD's and try to run the emulator myself then.

User avatar
Sobuno
Developer
Posts: 2589
Joined: Sun Mar 25, 2007 2:17 am
Contact:

Re: SWGAide for Emulators

Post by Sobuno » Sun Jan 15, 2012 3:41 pm

Okay, seems the EMU stores the profiles in the folder you create with the LaunchPad Enhanced Installer, so you have to point SWGAide to that folder as your installation directory. I have just uploaded a new version where you can actually do that. I had to start SWGAide, point it to the right directory and finish initialization, exit SWGAide, enter SWGAide, exit SWGAide and enter SWGAide for it to recognize my Liberator character.

So, in short:
  1. Download SWGAide 0.9.8-Sobuno (New version as of this post)
  2. Put it in an empty directory
  3. Launch SWGAide, making sure to select the SWGEmu directory created during the LaunchPad Enhanced installation as your SWG directory
  4. Exit SWGAide
  5. Launch SWGAide
  6. Exit SWGAide
  7. Launch SWGAide
  8. Enjoy (Hopefully)
(I think the multiple launches and exits have to do with the fetching of the server list from this site, but if it works now, I don't want to risk breaking it again)

Wieli
Novice Crafter
Posts: 23
Joined: Fri Apr 01, 2011 7:03 am

Re: SWGAide for Emulators

Post by Wieli » Sun Jan 15, 2012 5:15 pm

Thanks

It works exactly as you say now.

now i just have to figure out how to fix schematic etc.

hehe i have no knownledge in java, and im having a hard time getting to understand how Aide is built, but im sitting with the sourcecode atm so we will see if i will figure something out.

User avatar
Sobuno
Developer
Posts: 2589
Joined: Sun Mar 25, 2007 2:17 am
Contact:

Re: SWGAide for Emulators

Post by Sobuno » Sun Jan 15, 2012 6:14 pm

Wieli wrote:Thanks

It works exactly as you say now.

now i just have to figure out how to fix schematic etc.

hehe i have no knownledge in java, and im having a hard time getting to understand how Aide is built, but im sitting with the sourcecode atm so we will see if i will figure something out.
The schematics are fetched from this site, so to fix the schematics, you would have to fix them at this site. If you look in the crafting sub-folder in your SWGAide directory, you will see up to 4 XML-files. These are all fetched from here (Or whatever other site is set as the base-URL), so any changes would have to be made here.

Wieli
Novice Crafter
Posts: 23
Joined: Fri Apr 01, 2011 7:03 am

Re: SWGAide for Emulators

Post by Wieli » Mon Jan 16, 2012 4:16 pm

Ye i figured out that after alittle while, that alot of the data come stright from here. Since i couldnt find anything in the sourcecode.

NaeBliss
Apprentice Crafter
Posts: 59
Joined: Sat Jan 03, 2009 6:07 pm

Re: SWGAide for Emulators

Post by NaeBliss » Sun Jul 15, 2012 6:20 pm

Is there a new working version ever made? (with schem and all?)

Im beginning to miss that nifty tool!

Oh think i got it working, got the wrong version. :oops:

User avatar
Sobuno
Developer
Posts: 2589
Joined: Sun Mar 25, 2007 2:17 am
Contact:

Re: SWGAide for Emulators

Post by Sobuno » Mon Aug 20, 2012 6:31 pm

New version uploaded that fixes the schematic warnings regarding professions and levels.

No fixes for mail in this one.

xfortran
Novice Crafter
Posts: 8
Joined: Fri Jul 06, 2012 3:49 am

Re: SWGAide for Emulators

Post by xfortran » Sat Aug 25, 2012 4:23 am

schematics are working properly (yay! thank you)

Unfortunately, it no longer downloads resources for me. I have tried deleting it all and starting from scratch. Any suggestions?

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests