SWGAide and mail troubles

Moderator: Forum Moderator

Post Reply
Tharek Tolemac
Intermediate Crafter
Posts: 139
Joined: Sun Jun 03, 2007 8:48 am

SWGAide and mail troubles

Post by Tharek Tolemac » Wed May 11, 2011 4:04 pm

I dont know if this is a known issue already or an unknown bug. Maybe I just missed something in the notes. :)

But:

For a while now, it seems I cant delete trade mails anymore.

I have over 3.000 of them in SWGAide now, and if I delete them (move to trash, then permantly delete), they arent deleted from the folder SWGAide/mail.

Also, at the next start of SWGAide, they are all there again.

Strange is also, that the Date in the folder says, that all mails are generated right that moment when I started SWGAide. So, I cant even delete them manually in the Windows Explorer...

Any idea whats wrong?

Regards,
Tharek

PS: I heard you are coming to Farstar, Zimoon? Looking forward to meet you then. :)
Last edited by Zimoon on Wed May 11, 2011 8:36 pm, edited 1 time in total.
Reason: split to separate topic from wishlist

User avatar
Zimoon
Forum Moderator
Posts: 4817
Joined: Mon May 14, 2007 6:55 am
Location: Stockholm, SE
Contact:

Re: SWGAide and mail troubles

Post by Zimoon » Wed May 11, 2011 8:50 pm

I need to ask a few questions, then suggest a possible workaround.

In the mail options, which options are selected...
... the copy-to-SWGAide?
... the delete-after-copy?

Sorry for fuzzy wording but I don't have SWGAide where I am now.

It might be that you have only the first option but not the second, then SWGAide picks up mails in SWG's profiles folder. The same may happen if none is selected.

I thought I added some means to guard against this, but need to look into this again.

Workaround: enable delete-after-copy, then go to the Trade panel and at the File menu you select to archive trade mails. Now they are moved within the mails folder but to special folders that are ignored by SWGAide. And you can review them temporarily or restore them to the Trade again.

I will walk over the code chain during the weekend, right now

Tharek Tolemac
Intermediate Crafter
Posts: 139
Joined: Sun Jun 03, 2007 8:48 am

Re: SWGAide and mail troubles

Post by Tharek Tolemac » Fri May 20, 2011 6:57 pm

Sorry for the late reply.

I hadnt selected "delete after copy"... that might be the problem.

Seems to solve the issue :)

User avatar
Zimoon
Forum Moderator
Posts: 4817
Joined: Mon May 14, 2007 6:55 am
Location: Stockholm, SE
Contact:

Re: SWGAide and mail troubles

Post by Zimoon » Sat May 21, 2011 9:59 am

No worries.
Without having to track what is deleted in the SWGAide view this is expected when the "delete after copy" is not selected -- I don't know if people are interested in tracking that, it will make the DAT file slowly grow beyond sense and it would slow down startup somewhat, and also scanning for new mails for those that have thousands of mails. I am not a friend of that option.

What could be done is yet another option that takes effect only if "delete after copy" is selected: something like "delete completely" which deletes not only within SWGAide but also at SWG/profiles/... when a user deletes mails from the Trash folder. Of course it would be possible to make that to rather move mails to a backup folder within SWGAide/mails and people have to empty that one manually, whenever.

The bigger question is always, how much power should SWGAide have, and I am quite conservative and pro-safety, but that also makes things more cumbersome. I mean, if a player considers SWGAide his only interface to game-mail outside of the game he really wants SWGAide to delete when he selects to delete. But a player that just occasionally uses SWGAide would be angry if it suddenly deleted stuff he didn't intend to, right? That is why I try to add safety-belts in forms of backup files and folders.

Either way, I will indeed review this issue once I get the time, right now I am walking over some low-level communication stuff. When SWGCraft was off-line a few weeks ago (just for some hours mind you ;)) some errors surfaced that the code could handle better. I am also correcting so that harvesters do not continue to "work" in SWGAide when they are estimated to idle in-game. People have also asked for this and that in the past so I guess I should do another review of the "suggestions" thread. And it is summer too :lol:

Zimoon

Post Reply

Who is online

Users browsing this forum: Google [Bot] and 6 guests