SWGAide isn't starting anymore

Moderator: Forum Moderator

maninspace
Intermediate Crafter
Posts: 137
Joined: Sun Oct 21, 2007 2:47 pm
Location: Kiel, Germany

SWGAide isn't starting anymore

Post by maninspace » Wed Sep 29, 2010 10:38 pm

Hi Folks,
strange, but somehow SWGAide isn't starting anymoreon my PC, it stops at about 2/3 at the splash screen...

I am running this on WIN7 (Admin for Java is set!) and from USB stick.

Haven't checked on my notebook today, but it worked yesterday.

The only thing I have changed was, that I made up another Account for my GF on Win7, but I haven't changed anything for mine... *scratchhead*

Any ideas?

greetings and thanks for help

maninspace
SWG/DE Chronicle Master Correspondent

Europe-Farstar:
Horman Sheridan, Ta-awe Ifofa, Sahoo Arej, Anke Strassburg
Starsider:
Horman Sheridan, Hormon Sheridan

User avatar
Zimoon
Forum Moderator
Posts: 4817
Joined: Mon May 14, 2007 6:55 am
Location: Stockholm, SE
Contact:

Re: SWGAide isn't starting anymore

Post by Zimoon » Sat Oct 02, 2010 5:02 pm

First off, sorry for not being around for a week ... or more, I just haven't had the energy for it, and whatever the reason is for that is not public ;)

On to the money...

Does the log files give a clue? 1/3 sounds really early, wonder what that is :shock:

maninspace
Intermediate Crafter
Posts: 137
Joined: Sun Oct 21, 2007 2:47 pm
Location: Kiel, Germany

Re: SWGAide isn't starting anymore

Post by maninspace » Sat Oct 02, 2010 9:51 pm

Here it comes...

Exception in thread "pool-3-thread-1" java.lang.NumberFormatException: For input string: "<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML//EN">
<HTML>
<!--redir-->
<!--
<?xml version="1.0" encoding="UTF-8"?>
<WISPAccessGatewayParam
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:schemaLocation="https://apc.aptilo.com/sci/GenericAccess.xsd">
<Redirect>
<AccessProcedure>1.0</AccessProcedure>
<AccessLocation>NDR</AccessLocation>
<LocationName>NDR</LocationName>
<LoginURL>https://apc.aptilo.com/sci/process</LoginURL>
<AbortLoginURL>https://apc.aptilo.com/sci/logoff</AbortLoginURL>
<MessageType>100</MessageType>
<ResponseCode>0</ResponseCode>
</Redirect>
</WISPAccessGatewayParam>
-->
<HEAD>
<META HTTP-EQUIV="Pragma" CONTENT="no-cache">
<META HTTP-EQUIV="Expires" CONTENT="-1">
<META http-equiv="Refresh" content="1; url=https://pas.wifispectrum.co.uk/pas/star ... status.txt">
<TITLE>Forwarding...</TITLE>
</HEAD>
<BODY>
<p>
<a href="https://pas.wifispectrum.co.uk/pas/star ... ontinue</a>
</p>
</BODY>
</HTML>"
at java.lang.NumberFormatException.forInputString(Unknown Source)
at java.lang.Long.parseLong(Unknown Source)
at java.lang.Long.valueOf(Unknown Source)
at swg.swgcraft.SWGResourceManager.statusSWGCraftTime(SWGResourceManager.java:1372)
at swg.swgcraft.SWGResourceManager.statusIsUpdated(SWGResourceManager.java:1293)
at swg.swgcraft.SWGResourceManager.isGalaxyUpdated(SWGResourceManager.java:826)
at swg.swgcraft.SWGResourceManager.downloadHelper(SWGResourceManager.java:336)
at swg.swgcraft.SWGResourceManager.access$0(SWGResourceManager.java:334)
at swg.swgcraft.SWGResourceManager$2.run(SWGResourceManager.java:300)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)
Exception in thread "AWT-EventQueue-0" java.lang.ArrayIndexOutOfBoundsException: 2
at javax.swing.plaf.basic.BasicTabbedPaneUI.paintTabArea(Unknown Source)
at javax.swing.plaf.basic.BasicTabbedPaneUI.paint(Unknown Source)
at javax.swing.plaf.metal.MetalTabbedPaneUI.paint(Unknown Source)
at javax.swing.plaf.metal.MetalTabbedPaneUI.update(Unknown Source)
at javax.swing.JComponent.paintComponent(Unknown Source)
at javax.swing.JComponent.paint(Unknown Source)
at javax.swing.JComponent.paintChildren(Unknown Source)
at javax.swing.JComponent.paint(Unknown Source)
at javax.swing.JComponent.paintChildren(Unknown Source)
at javax.swing.JComponent.paint(Unknown Source)
at javax.swing.JComponent.paintChildren(Unknown Source)
at javax.swing.JComponent.paint(Unknown Source)
at javax.swing.JComponent.paintChildren(Unknown Source)
at javax.swing.JComponent.paint(Unknown Source)
at javax.swing.JLayeredPane.paint(Unknown Source)
at javax.swing.JComponent.paintChildren(Unknown Source)
at javax.swing.JComponent.paintToOffscreen(Unknown Source)
at javax.swing.RepaintManager$PaintManager.paintDoubleBuffered(Unknown Source)
at javax.swing.RepaintManager$PaintManager.paint(Unknown Source)
at javax.swing.RepaintManager.paint(Unknown Source)
at javax.swing.JComponent.paint(Unknown Source)
at java.awt.GraphicsCallback$PaintCallback.run(Unknown Source)
at sun.awt.SunGraphicsCallback.runOneComponent(Unknown Source)
at sun.awt.SunGraphicsCallback.runComponents(Unknown Source)
at java.awt.Container.paint(Unknown Source)
at java.awt.Window.paint(Unknown Source)
at javax.swing.RepaintManager.paintDirtyRegions(Unknown Source)
at javax.swing.RepaintManager.paintDirtyRegions(Unknown Source)
at javax.swing.RepaintManager.seqPaintDirtyRegions(Unknown Source)
at javax.swing.SystemEventQueueUtilities$ComponentWorkRequest.run(Unknown Source)
at java.awt.event.InvocationEvent.dispatch(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)
[Wed Sep 15 20:20:18 CEST 2010 | version 0.8.15 == EXCEPTION == SimplePrefsKeeper:store: null
java.util.ConcurrentModificationException
at java.util.ArrayList.writeObject(Unknown Source)
at sun.reflect.GeneratedMethodAccessor21.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at java.io.ObjectStreamClass.invokeWriteObject(Unknown Source)
at java.io.ObjectOutputStream.writeSerialData(Unknown Source)
at java.io.ObjectOutputStream.writeOrdinaryObject(Unknown Source)
at java.io.ObjectOutputStream.writeObject0(Unknown Source)
at java.io.ObjectOutputStream.writeObject(Unknown Source)
at swg.crafting.resources.SWGResourceSet.writeObject(SWGResourceSet.java:647)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at java.io.ObjectStreamClass.invokeWriteObject(Unknown Source)
at java.io.ObjectOutputStream.writeSerialData(Unknown Source)
at java.io.ObjectOutputStream.writeOrdinaryObject(Unknown Source)
at java.io.ObjectOutputStream.writeObject0(Unknown Source)
at java.io.ObjectOutputStream.writeObject(Unknown Source)
at java.util.HashMap.writeObject(Unknown Source)
at sun.reflect.GeneratedMethodAccessor19.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at java.io.ObjectStreamClass.invokeWriteObject(Unknown Source)
at java.io.ObjectOutputStream.writeSerialData(Unknown Source)
at java.io.ObjectOutputStream.writeOrdinaryObject(Unknown Source)
at java.io.ObjectOutputStream.writeObject0(Unknown Source)
at java.io.ObjectOutputStream.writeObject(Unknown Source)
at java.util.Hashtable.writeObject(Unknown Source)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at java.io.ObjectStreamClass.invokeWriteObject(Unknown Source)
at java.io.ObjectOutputStream.writeSerialData(Unknown Source)
at java.io.ObjectOutputStream.writeOrdinaryObject(Unknown Source)
at java.io.ObjectOutputStream.writeObject0(Unknown Source)
at java.io.ObjectOutputStream.defaultWriteFields(Unknown Source)
at java.io.ObjectOutputStream.writeSerialData(Unknown Source)
at java.io.ObjectOutputStream.writeOrdinaryObject(Unknown Source)
at java.io.ObjectOutputStream.writeObject0(Unknown Source)
at java.io.ObjectOutputStream.writeObject(Unknown Source)
at swg.tools.SimplePrefsKeeper.store(SimplePrefsKeeper.java:265)
at swg.gui.SWGFrame$23.actionPerformed(SWGFrame.java:1745)
at javax.swing.Timer.fireActionPerformed(Unknown Source)
at javax.swing.Timer$DoPostEvent.run(Unknown Source)
at java.awt.event.InvocationEvent.dispatch(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)
[Wed Sep 15 20:56:38 CEST 2010 | version 0.8.15 == EXCEPTION == SWGFrame:showErrorMailOption: Please, describe what you think caused the problem and attach or inline the error log to the mail.
Hopefully the error log opens in an editor automatically. Otherwise it is located in the folder wher you dropped SWGAide, in the "logs" folder.
You may delete the error log file once it is sent.
Thanks
Zimoon @ Europe-Chimaera: Failed to open mailto:simongronlund@gmail.com?SUBJECT=SWGAide%20Bug%20Report&BODY=Please,%20describe%20what%20you%20think%20caused%20the%20problem%20and%20attach%20or%20inline%20the%20error%20log%20to%20the%20mail.%0AHopefully%20the%20error%20log%20opens%20in%20an%20editor%20automatically.%20Otherwise%20it%20is%20located%20in%20the%20folder%20wher%20you%20dropped%20SWGAide,%20in%20the%20%22logs%22%20folder.%0AYou%20may%20delete%20the%20error%20log%20file%20once%20it%20is%20sent.%0AThanks%0AZimoon%20@%20Europe-Chimaera. Error message: Der angegebenen Datei ist keine Anwendung zugeordnet.

java.io.IOException: Failed to open mailto:simongronlund@gmail.com?SUBJECT=SWGAide%20Bug%20Report&BODY=Please,%20describe%20what%20you%20think%20caused%20the%20problem%20and%20attach%20or%20inline%20the%20error%20log%20to%20the%20mail.%0AHopefully%20the%20error%20log%20opens%20in%20an%20editor%20automatically.%20Otherwise%20it%20is%20located%20in%20the%20folder%20wher%20you%20dropped%20SWGAide,%20in%20the%20%22logs%22%20folder.%0AYou%20may%20delete%20the%20error%20log%20file%20once%20it%20is%20sent.%0AThanks%0AZimoon%20@%20Europe-Chimaera. Error message: Der angegebenen Datei ist keine Anwendung zugeordnet.

at sun.awt.windows.WDesktopPeer.ShellExecute(Unknown Source)
at sun.awt.windows.WDesktopPeer.mail(Unknown Source)
at java.awt.Desktop.mail(Unknown Source)
at swg.gui.SWGFrame$22.run(SWGFrame.java:1667)
at java.awt.event.InvocationEvent.dispatch(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)
=== STOPPED: Thu Sep 16 03:24:28 CEST 2010

Exception in thread "pool-5-thread-1" java.lang.NumberFormatException: For input string: "<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML//EN">
<HTML>
<!--redir-->
<!--
<?xml version="1.0" encoding="UTF-8"?>
<WISPAccessGatewayParam
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:schemaLocation="https://apc.aptilo.com/sci/GenericAccess.xsd">
<Redirect>
<AccessProcedure>1.0</AccessProcedure>
<AccessLocation>NDR</AccessLocation>
<LocationName>NDR</LocationName>
<LoginURL>https://apc.aptilo.com/sci/process</LoginURL>
<AbortLoginURL>https://apc.aptilo.com/sci/logoff</AbortLoginURL>
<MessageType>100</MessageType>
<ResponseCode>0</ResponseCode>
</Redirect>
</WISPAccessGatewayParam>
-->
<HEAD>
<META HTTP-EQUIV="Pragma" CONTENT="no-cache">
<META HTTP-EQUIV="Expires" CONTENT="-1">
<META http-equiv="Refresh" content="1; url=https://pas.wifispectrum.co.uk/pas/star ... status.txt">
<TITLE>Forwarding...</TITLE>
</HEAD>
<BODY>
<p>
<a href="https://pas.wifispectrum.co.uk/pas/star ... ontinue</a>
</p>
</BODY>
</HTML>"
at java.lang.NumberFormatException.forInputString(Unknown Source)
at java.lang.Long.parseLong(Unknown Source)
at java.lang.Long.valueOf(Unknown Source)
at swg.swgcraft.SWGResourceManager.statusSWGCraftTime(SWGResourceManager.java:1372)
at swg.swgcraft.SWGResourceManager.statusIsUpdated(SWGResourceManager.java:1293)
at swg.swgcraft.SWGResourceManager.isGalaxyUpdated(SWGResourceManager.java:826)
at swg.swgcraft.SWGResourceManager.downloadHelper(SWGResourceManager.java:336)
at swg.swgcraft.SWGResourceManager.access$0(SWGResourceManager.java:334)
at swg.swgcraft.SWGResourceManager$2.run(SWGResourceManager.java:300)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)
[Wed Sep 29 18:16:06 CEST 2010 | version 0.8.15 == EXCEPTION == SWGNotes:getNotesAsString: : C:\Program Files (x86)\StarWarsGalaxies\profiles\XXX\shop.txt (Das System kann die angegebene Datei nicht finden)
java.io.FileNotFoundException: C:\Program Files (x86)\StarWarsGalaxies\profiles\XXX\shop.txt (Das System kann die angegebene Datei nicht finden)
at java.io.FileInputStream.open(Native Method)
at java.io.FileInputStream.<init>(Unknown Source)
at java.io.FileReader.<init>(Unknown Source)
at swg.model.SWGNotes.getNotesAsString(SWGNotes.java:242)
at swg.gui.SWGNotesPane.<init>(SWGNotesPane.java:134)
at swg.gui.tree.SWGNotesNode.getNotesPane(SWGNotesNode.java:115)
at swg.gui.tree.SWGNotesNode.focusGained(SWGNotesNode.java:72)
at swg.gui.SWGMainTab.focusChanged(SWGMainTab.java:158)
at swg.gui.SWGMainTab$3.stateChanged(SWGMainTab.java:131)
at javax.swing.JTabbedPane.fireStateChanged(Unknown Source)
at javax.swing.JTabbedPane$ModelListener.stateChanged(Unknown Source)
at javax.swing.DefaultSingleSelectionModel.fireStateChanged(Unknown Source)
at javax.swing.DefaultSingleSelectionModel.setSelectedIndex(Unknown Source)
at javax.swing.JTabbedPane.setSelectedIndexImpl(Unknown Source)
at javax.swing.JTabbedPane.setSelectedIndex(Unknown Source)
at javax.swing.JTabbedPane.insertTab(Unknown Source)
at javax.swing.JTabbedPane.addTab(Unknown Source)
at javax.swing.JTabbedPane.add(Unknown Source)
at swg.gui.SWGFrame.populateTabPane(SWGFrame.java:1431)
at swg.gui.SWGFrame.initTabPane(SWGFrame.java:1076)
at swg.gui.SWGFrame.delayedConstructor(SWGFrame.java:405)
at swg.SWGAide.main(SWGAide.java:179)
[Wed Sep 29 18:16:06 CEST 2010 | version 0.8.15 == EXCEPTION == Caught in main: null
java.lang.NullPointerException
at swg.model.SWGNotes.getNotesAsString(SWGNotes.java:253)
at swg.gui.SWGNotesPane.<init>(SWGNotesPane.java:134)
at swg.gui.tree.SWGNotesNode.getNotesPane(SWGNotesNode.java:115)
at swg.gui.tree.SWGNotesNode.focusGained(SWGNotesNode.java:72)
at swg.gui.SWGMainTab.focusChanged(SWGMainTab.java:158)
at swg.gui.SWGMainTab$3.stateChanged(SWGMainTab.java:131)
at javax.swing.JTabbedPane.fireStateChanged(Unknown Source)
at javax.swing.JTabbedPane$ModelListener.stateChanged(Unknown Source)
at javax.swing.DefaultSingleSelectionModel.fireStateChanged(Unknown Source)
at javax.swing.DefaultSingleSelectionModel.setSelectedIndex(Unknown Source)
at javax.swing.JTabbedPane.setSelectedIndexImpl(Unknown Source)
at javax.swing.JTabbedPane.setSelectedIndex(Unknown Source)
at javax.swing.JTabbedPane.insertTab(Unknown Source)
at javax.swing.JTabbedPane.addTab(Unknown Source)
at javax.swing.JTabbedPane.add(Unknown Source)
at swg.gui.SWGFrame.populateTabPane(SWGFrame.java:1431)
at swg.gui.SWGFrame.initTabPane(SWGFrame.java:1076)
at swg.gui.SWGFrame.delayedConstructor(SWGFrame.java:405)
at swg.SWGAide.main(SWGAide.java:179)
[Wed Sep 29 18:31:21 CEST 2010 | version 0.8.15 == EXCEPTION == SWGNotes:getNotesAsString: : C:\Program Files (x86)\StarWarsGalaxies\profiles\XXX\shop.txt (Das System kann die angegebene Datei nicht finden)
java.io.FileNotFoundException: C:\Program Files (x86)\StarWarsGalaxies\profiles\XXX\shop.txt (Das System kann die angegebene Datei nicht finden)
at java.io.FileInputStream.open(Native Method)
at java.io.FileInputStream.<init>(Unknown Source)
at java.io.FileReader.<init>(Unknown Source)
at swg.model.SWGNotes.getNotesAsString(SWGNotes.java:242)
at swg.gui.SWGNotesPane.<init>(SWGNotesPane.java:134)
at swg.gui.tree.SWGNotesNode.getNotesPane(SWGNotesNode.java:115)
at swg.gui.tree.SWGNotesNode.focusGained(SWGNotesNode.java:72)
at swg.gui.SWGMainTab.focusChanged(SWGMainTab.java:158)
at swg.gui.SWGMainTab$3.stateChanged(SWGMainTab.java:131)
at javax.swing.JTabbedPane.fireStateChanged(Unknown Source)
at javax.swing.JTabbedPane$ModelListener.stateChanged(Unknown Source)
at javax.swing.DefaultSingleSelectionModel.fireStateChanged(Unknown Source)
at javax.swing.DefaultSingleSelectionModel.setSelectedIndex(Unknown Source)
at javax.swing.JTabbedPane.setSelectedIndexImpl(Unknown Source)
at javax.swing.JTabbedPane.setSelectedIndex(Unknown Source)
at javax.swing.JTabbedPane.insertTab(Unknown Source)
at javax.swing.JTabbedPane.addTab(Unknown Source)
at javax.swing.JTabbedPane.add(Unknown Source)
at swg.gui.SWGFrame.populateTabPane(SWGFrame.java:1431)
at swg.gui.SWGFrame.initTabPane(SWGFrame.java:1076)
at swg.gui.SWGFrame.delayedConstructor(SWGFrame.java:405)
at swg.SWGAide.main(SWGAide.java:179)
[Wed Sep 29 18:31:21 CEST 2010 | version 0.8.15 == EXCEPTION == Caught in main: null
java.lang.NullPointerException
at swg.model.SWGNotes.getNotesAsString(SWGNotes.java:253)
at swg.gui.SWGNotesPane.<init>(SWGNotesPane.java:134)
at swg.gui.tree.SWGNotesNode.getNotesPane(SWGNotesNode.java:115)
at swg.gui.tree.SWGNotesNode.focusGained(SWGNotesNode.java:72)
at swg.gui.SWGMainTab.focusChanged(SWGMainTab.java:158)
at swg.gui.SWGMainTab$3.stateChanged(SWGMainTab.java:131)
at javax.swing.JTabbedPane.fireStateChanged(Unknown Source)
at javax.swing.JTabbedPane$ModelListener.stateChanged(Unknown Source)
at javax.swing.DefaultSingleSelectionModel.fireStateChanged(Unknown Source)
at javax.swing.DefaultSingleSelectionModel.setSelectedIndex(Unknown Source)
at javax.swing.JTabbedPane.setSelectedIndexImpl(Unknown Source)
at javax.swing.JTabbedPane.setSelectedIndex(Unknown Source)
at javax.swing.JTabbedPane.insertTab(Unknown Source)
at javax.swing.JTabbedPane.addTab(Unknown Source)
at javax.swing.JTabbedPane.add(Unknown Source)
at swg.gui.SWGFrame.populateTabPane(SWGFrame.java:1431)
at swg.gui.SWGFrame.initTabPane(SWGFrame.java:1076)
at swg.gui.SWGFrame.delayedConstructor(SWGFrame.java:405)
at swg.SWGAide.main(SWGAide.java:179)
Exception in thread "pool-3-thread-1" java.lang.NumberFormatException: For input string: "<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML//EN">
<HTML>
<!--redir-->
<!--
<?xml version="1.0" encoding="UTF-8"?>
<WISPAccessGatewayParam
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:schemaLocation="https://apc.aptilo.com/sci/GenericAccess.xsd">
<Redirect>
<AccessProcedure>1.0</AccessProcedure>
<AccessLocation>NDR</AccessLocation>
<LocationName>NDR</LocationName>
<LoginURL>https://apc.aptilo.com/sci/process</LoginURL>
<AbortLoginURL>https://apc.aptilo.com/sci/logoff</AbortLoginURL>
<MessageType>100</MessageType>
<ResponseCode>0</ResponseCode>
</Redirect>
</WISPAccessGatewayParam>
-->
<HEAD>
<META HTTP-EQUIV="Pragma" CONTENT="no-cache">
<META HTTP-EQUIV="Expires" CONTENT="-1">
<META http-equiv="Refresh" content="1; url=http://www.swgcraft.org/dev/public/status.txt">
<TITLE>Forwarding...</TITLE>
</HEAD>
<BODY>
<p>
<a href="http://www.swgcraft.org/dev/public/stat ... ontinue</a>
</p>
</BODY>
</HTML>"
at java.lang.NumberFormatException.forInputString(Unknown Source)
at java.lang.Long.parseLong(Unknown Source)
at java.lang.Long.valueOf(Unknown Source)
at swg.swgcraft.SWGResourceManager.statusSWGCraftTime(SWGResourceManager.java:1372)
at swg.swgcraft.SWGResourceManager.statusIsUpdated(SWGResourceManager.java:1293)
at swg.swgcraft.SWGResourceManager.isGalaxyUpdated(SWGResourceManager.java:826)
at swg.swgcraft.SWGResourceManager.downloadHelper(SWGResourceManager.java:336)
at swg.swgcraft.SWGResourceManager.access$0(SWGResourceManager.java:334)
at swg.swgcraft.SWGResourceManager$2.run(SWGResourceManager.java:300)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)
[Sat Oct 02 23:47:23 CEST 2010 | version 0.8.15 == EXCEPTION == SWGNotes:getNotesAsString: : C:\Program Files (x86)\StarWarsGalaxies\profiles\XXX\shop.txt (Das System kann die angegebene Datei nicht finden)
java.io.FileNotFoundException: C:\Program Files (x86)\StarWarsGalaxies\profiles\XXX\shop.txt (Das System kann die angegebene Datei nicht finden)
at java.io.FileInputStream.open(Native Method)
at java.io.FileInputStream.<init>(Unknown Source)
at java.io.FileReader.<init>(Unknown Source)
at swg.model.SWGNotes.getNotesAsString(SWGNotes.java:242)
at swg.gui.SWGNotesPane.<init>(SWGNotesPane.java:134)
at swg.gui.tree.SWGNotesNode.getNotesPane(SWGNotesNode.java:115)
at swg.gui.tree.SWGNotesNode.focusGained(SWGNotesNode.java:72)
at swg.gui.SWGMainTab.focusChanged(SWGMainTab.java:158)
at swg.gui.SWGMainTab$3.stateChanged(SWGMainTab.java:131)
at javax.swing.JTabbedPane.fireStateChanged(Unknown Source)
at javax.swing.JTabbedPane$ModelListener.stateChanged(Unknown Source)
at javax.swing.DefaultSingleSelectionModel.fireStateChanged(Unknown Source)
at javax.swing.DefaultSingleSelectionModel.setSelectedIndex(Unknown Source)
at javax.swing.JTabbedPane.setSelectedIndexImpl(Unknown Source)
at javax.swing.JTabbedPane.setSelectedIndex(Unknown Source)
at javax.swing.JTabbedPane.insertTab(Unknown Source)
at javax.swing.JTabbedPane.addTab(Unknown Source)
at javax.swing.JTabbedPane.add(Unknown Source)
at swg.gui.SWGFrame.populateTabPane(SWGFrame.java:1431)
at swg.gui.SWGFrame.initTabPane(SWGFrame.java:1076)
at swg.gui.SWGFrame.delayedConstructor(SWGFrame.java:405)
at swg.SWGAide.main(SWGAide.java:179)
[Sat Oct 02 23:47:23 CEST 2010 | version 0.8.15 == EXCEPTION == Caught in main: null
java.lang.NullPointerException
at swg.model.SWGNotes.getNotesAsString(SWGNotes.java:253)
at swg.gui.SWGNotesPane.<init>(SWGNotesPane.java:134)
at swg.gui.tree.SWGNotesNode.getNotesPane(SWGNotesNode.java:115)
at swg.gui.tree.SWGNotesNode.focusGained(SWGNotesNode.java:72)
at swg.gui.SWGMainTab.focusChanged(SWGMainTab.java:158)
at swg.gui.SWGMainTab$3.stateChanged(SWGMainTab.java:131)
at javax.swing.JTabbedPane.fireStateChanged(Unknown Source)
at javax.swing.JTabbedPane$ModelListener.stateChanged(Unknown Source)
at javax.swing.DefaultSingleSelectionModel.fireStateChanged(Unknown Source)
at javax.swing.DefaultSingleSelectionModel.setSelectedIndex(Unknown Source)
at javax.swing.JTabbedPane.setSelectedIndexImpl(Unknown Source)
at javax.swing.JTabbedPane.setSelectedIndex(Unknown Source)
at javax.swing.JTabbedPane.insertTab(Unknown Source)
at javax.swing.JTabbedPane.addTab(Unknown Source)
at javax.swing.JTabbedPane.add(Unknown Source)
at swg.gui.SWGFrame.populateTabPane(SWGFrame.java:1431)
at swg.gui.SWGFrame.initTabPane(SWGFrame.java:1076)
at swg.gui.SWGFrame.delayedConstructor(SWGFrame.java:405)
at swg.SWGAide.main(SWGAide.java:179)
SWG/DE Chronicle Master Correspondent

Europe-Farstar:
Horman Sheridan, Ta-awe Ifofa, Sahoo Arej, Anke Strassburg
Starsider:
Horman Sheridan, Hormon Sheridan

User avatar
Sobuno
Developer
Posts: 2589
Joined: Sun Mar 25, 2007 2:17 am
Contact:

Re: SWGAide isn't starting anymore

Post by Sobuno » Sat Oct 02, 2010 11:02 pm

As far as I can tell, it tries to access the status.txt file to determine whether a new currentresources file has been made yet. It seems your traffic is getting routed through https://pas.wifispectrum.co.uk/ etc., possibly a site you need to login to in order to use the web?. Anyway, this page makes SWGAide crash as it expects the unix timestamp from the status.txt file, not a fully-fledged webpage.

That's my theory at least.

So: Do you need to login through a site to use the web? And have you done this prior to opening SWGAide?

maninspace
Intermediate Crafter
Posts: 137
Joined: Sun Oct 21, 2007 2:47 pm
Location: Kiel, Germany

Re: SWGAide isn't starting anymore

Post by maninspace » Sat Oct 02, 2010 11:16 pm

When using my notebook I sometimes use this site to log in...
but the problem occurse on my PC...

and I have used this many times on both already - without any problems :(
SWG/DE Chronicle Master Correspondent

Europe-Farstar:
Horman Sheridan, Ta-awe Ifofa, Sahoo Arej, Anke Strassburg
Starsider:
Horman Sheridan, Hormon Sheridan

User avatar
Sobuno
Developer
Posts: 2589
Joined: Sun Mar 25, 2007 2:17 am
Contact:

Re: SWGAide isn't starting anymore

Post by Sobuno » Sat Oct 02, 2010 11:41 pm

I am afraid I can't be of further assistance - I dug down in the code, but my trail ends at the SWGAide.DAT file which I have no idea how to read. I am suspecting the base URL or status file URL has somehow been changed, or that that site is rerouting traffic for some reason (The page mentioned in your log file has "Forwarding" as the title), but these are just wild guesses.

User avatar
Zimoon
Forum Moderator
Posts: 4817
Joined: Mon May 14, 2007 6:55 am
Location: Stockholm, SE
Contact:

Re: SWGAide isn't starting anymore

Post by Zimoon » Sun Oct 03, 2010 10:05 am

Yes, I am with Sobuno here, your ISP is playing games with you. I wonder what happens if you first visit any other web page with a web browser and then launch SWGAide, then you you would be logged in ... at least for some period of time.

It is a shame that some ISP use this non-standard network fashion to request you to login via a web page. But that is their way of forcing you to view their advertisements and feel bonded with them ... do you feel that? :P

I can, or rather must, fix SWGAide so it does not choke over this error, but that will just make it start, you will still not get in contact with SWGCraft and then you are without resource updates.

You, on the other hand, must call your ISP and ask how to overcome this issue. I can assure you that SWGAide is not the only application that cannot connect to a standard Internet resource. Perhaps the only one that you use but not globally.

Zimoon

User avatar
Zimoon
Forum Moderator
Posts: 4817
Joined: Mon May 14, 2007 6:55 am
Location: Stockholm, SE
Contact:

Re: SWGAide isn't starting anymore

Post by Zimoon » Sun Oct 03, 2010 10:14 am

maninspace wrote:at swg.swgcraft.SWGResourceManager.statusSWGCraftTime(SWGResourceManager.java:1372)
This is fixed, widened the type of errors that are caught so crap->numbers won't cause a greater error. Will try to get a new version out shortly.

User avatar
Zimoon
Forum Moderator
Posts: 4817
Joined: Mon May 14, 2007 6:55 am
Location: Stockholm, SE
Contact:

Re: SWGAide isn't starting anymore

Post by Zimoon » Sun Oct 03, 2010 10:47 am

maninspace wrote:java.io.FileNotFoundException: C:\Program Files (x86)\StarWarsGalaxies\profiles\XXX\shop.txt
Changed this so a debug rather than error message is written as these are rather expected. Also added checks for possible NULL references in the notes section. This is old code that I planned ti walk over while upgrading SWGAide to allow for mobile use over any computer but as I see the error in the log 8)

Zimoon

maninspace
Intermediate Crafter
Posts: 137
Joined: Sun Oct 21, 2007 2:47 pm
Location: Kiel, Germany

Re: SWGAide isn't starting anymore

Post by maninspace » Sun Oct 03, 2010 11:55 am

Ehm,
just to be sure, that we are talking about the same...

the mentioned ISP I am just using while at work. That is a wireless accesspoint, offered by our company.
When using this ISP, I DON'T have this problem of SWGAide not starting, while working there.
When using this ISP, I get a 24hrs access, after that, it will be resetted and if some programs are running, that need an internet access, I will have to re-register...

But now I am trying to start the same program - stored on my USB-Stick - working on my PC at home. Normal LAN access point via my own router...
And while I am using it here, I have the problem...

I already used it some weeks via both accesspoints, without any problems.
The only change I made at home was, that I opened another useraccount for my GF on my PC (as mentioned, Win7, did the workaround with Java as Admin!)
SWG/DE Chronicle Master Correspondent

Europe-Farstar:
Horman Sheridan, Ta-awe Ifofa, Sahoo Arej, Anke Strassburg
Starsider:
Horman Sheridan, Hormon Sheridan

User avatar
Sobuno
Developer
Posts: 2589
Joined: Sun Mar 25, 2007 2:17 am
Contact:

Re: SWGAide isn't starting anymore

Post by Sobuno » Sun Oct 03, 2010 12:09 pm

That does indeed sound odd.

Zimoon, does SWGAide cache DNS lookups in some way? Possibly got cached at work (Where he immediately gets forwarded or something) and then doesn't work at home.

maninspace, does a new installation of SWGAide work?

maninspace
Intermediate Crafter
Posts: 137
Joined: Sun Oct 21, 2007 2:47 pm
Location: Kiel, Germany

Re: SWGAide isn't starting anymore

Post by maninspace » Sun Oct 03, 2010 3:13 pm

Not till now...

how do I backup my data (guards etc.) without the program?
SWG/DE Chronicle Master Correspondent

Europe-Farstar:
Horman Sheridan, Ta-awe Ifofa, Sahoo Arej, Anke Strassburg
Starsider:
Horman Sheridan, Hormon Sheridan

User avatar
Zimoon
Forum Moderator
Posts: 4817
Joined: Mon May 14, 2007 6:55 am
Location: Stockholm, SE
Contact:

Re: SWGAide isn't starting anymore

Post by Zimoon » Sun Oct 03, 2010 3:59 pm

Sobuno wrote:That does indeed sound odd.

Zimoon, does SWGAide cache DNS lookups in some way? Possibly got cached at work (Where he immediately gets forwarded or something) and then doesn't work at home.
Nope, nothing such. SWGAide never fiddles with networking but just uses services of the host, Windows is this case. Neither is a full URL or anything such stored in the DAT file, in fact the DAT file contains only what is visible at the Options >> SWGCraft dialog and that is only if it is not a default value, which means that most often nothing is in the DAT file whatsoever.

maninspace, does a new installation of SWGAide work?
Should not be necessary because SWGAide does not store networking details of any kind. Exit and relaunch and everything is new.

However, if Windows caches something or not, that is another story.
I have seen this type of error reported before and it has 100.0% been related to the ISP and how the connection is done. As is seen in the error message the ISP does not respond with what was asked for (which is the content of a tiny file) but responds with a web page. Compare that with how Google Sites responds, if I browse to the "SWG-current-version" by a web browser I get a web page back, which displays the current version, but if I call for the very same URL via SWGAide i get the tiny text content back ... as a server is supposed to work.

I understand that the easiest to blame is the application, but in this case it is 100% innocent. One could argue that it should support whatever silly stuff the world throws at it ... or not. What I really wish, though, is that we find the solution to this problem, and that is somewhere in how the network works, or Windows.

Zimoon

User avatar
Zimoon
Forum Moderator
Posts: 4817
Joined: Mon May 14, 2007 6:55 am
Location: Stockholm, SE
Contact:

Re: SWGAide isn't starting anymore

Post by Zimoon » Sun Oct 03, 2010 4:09 pm

maninspace wrote:Ehm,
just to be sure, that we are talking about the same...

the mentioned ISP I am just using while at work. That is a wireless accesspoint, offered by our company.
When using this ISP, I DON'T have this problem of SWGAide not starting, while working there.
When using this ISP, I get a 24hrs access, after that, it will be resetted and if some programs are running, that need an internet access, I will have to re-register...
I read the above as ... SWGAide is working at work, right?
Does SWGAide continue to work when at home, until the "ticket" times out?


But now I am trying to start the same program - stored on my USB-Stick - working on my PC at home. Normal LAN access point via my own router...
And while I am using it here, I have the problem...
Hmmm, what else is at that USB-stick? Is it a plain USB-stick (storage only) or is it somehow encrypted or have other funny functionality which fools Windows into re-using some cached stuff it might have? Believe me, many USB-sticks these days are not what they used to be when I was younger.

I already used it some weeks via both accesspoints, without any problems.
The only change I made at home was, that I opened another useraccount for my GF on my PC (as mentioned, Win7, did the workaround with Java as Admin!)
I am not sure how another user account could make a difference but I guess that these days it sure can. Windows and UAC and anything with "sequr" in it is a wormhole of troubles these days, no wonder people disable security 8)

Either way, the only error message I found in the log you posted was about that ISP that throws a web page at it rather than a small text reading such as "123456790". Whether the new account makes a difference or not is beyond me, I am sorry.
/Zimoon

User avatar
Zimoon
Forum Moderator
Posts: 4817
Joined: Mon May 14, 2007 6:55 am
Location: Stockholm, SE
Contact:

Re: SWGAide isn't starting anymore

Post by Zimoon » Sun Oct 03, 2010 4:15 pm

maninspace wrote:Not till now...

how do I backup my data (guards etc.) without the program?
What if you open the USB stick and "drag" the folder for SWGAide to somewhere at your PC. Depending on your type of admin rights, either to the SWG folder itself, or to your My Documents folder. SWGAide as such has no problem with files within its own folder, but it still has problems if the correct path to SWG is different from one computer to the other. I read this as you have a setup with "identical" setups of SWG to get SWGAide to cope with them, right?

The above, to run from a copied folder (including the DAT file) would possibly override weird stuff with the USB stick. But I admit I am walking blindfolded here.

Zimoon

EDITED: sorry, forgot ... you said SWGAide run fine at work. Export guards, inventory etc while there. But I hope we can rather resolve the real issue than using a crude workaround.

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests