cant install swgaide

Moderator: Forum Moderator

Post Reply
sikocbrayt
Novice Crafter
Posts: 3
Joined: Sat Feb 06, 2010 10:36 pm

cant install swgaide

Post by sikocbrayt » Tue Aug 10, 2010 8:13 am

Hi i have tried to install swgaide and i have failed :)

i have installed java downloaded the files from http://sites.google.com/site/simongronl ... edirects=0

and run the jar file, program opens finds my swg folder, than start to scan and stops.

executing step 2 and step 3 it stops the progress bar hangs at nearly %25, i have left it for 2 hours nothing changed, when i press the done button, program opens, i see my acount on the main tab, and when i clicked it i only see my macros, nothing except, the other tabs arent working says
i should have select a character from the main tab, or error msg that a some files missing.

the error log on swgaide log folder is below,

what can i do?


Exception in thread "AWT-EventQueue-0" java.lang.IllegalArgumentException: No enum const class swg.model.SWGCGalaxy.STARSİDER
at java.lang.Enum.valueOf(Unknown Source)
at swg.model.SWGCGalaxy.valueOf(SWGCGalaxy.java:1)
at swg.model.SWGCGalaxy.getFromName(SWGCGalaxy.java:286)
at swg.swgcraft.SWGResourceManager.updateMainGalaxy(SWGResourceManager.java:245)
at swg.swgcraft.SWGResourceManager$1.actionPerformed(SWGResourceManager.java:211)
at javax.swing.Timer.fireActionPerformed(Unknown Source)
at javax.swing.Timer$DoPostEvent.run(Unknown Source)
at java.awt.event.InvocationEvent.dispatch(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)
[Tue Aug 10 11:09:52 EEST 2010 | version 0.8.12 == EXCEPTION == SWGInitialize:iniateUniverse: No enum const class swg.model.SWGCGalaxy.CHİLASTRA
java.lang.IllegalArgumentException: No enum const class swg.model.SWGCGalaxy.CHİLASTRA
at java.lang.Enum.valueOf(Unknown Source)
at swg.model.SWGCGalaxy.valueOf(SWGCGalaxy.java:1)
at swg.model.SWGCGalaxy.getFromName(SWGCGalaxy.java:286)
at swg.model.SWGGalaxy.<init>(SWGGalaxy.java:102)
at swg.model.SWGGalaxy.scanForNewGalaxies(SWGGalaxy.java:469)
at swg.gui.SWGInitialize.scanForGalaxies(SWGInitialize.java:605)
at swg.gui.SWGInitialize.scanAll(SWGInitialize.java:469)
at swg.gui.SWGInitialize$9.doInBackground(SWGInitialize.java:342)
at swg.gui.SWGInitialize$9.doInBackground(SWGInitialize.java:1)
at javax.swing.SwingWorker$1.call(Unknown Source)
at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
at java.util.concurrent.FutureTask.run(Unknown Source)
at javax.swing.SwingWorker.run(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)

User avatar
Zimoon
Forum Moderator
Posts: 4817
Joined: Mon May 14, 2007 6:55 am
Location: Stockholm, SE
Contact:

Re: cant install swgaide

Post by Zimoon » Tue Aug 10, 2010 11:17 am

sikocbrayt wrote:...
No enum const class swg.model.SWGCGalaxy.STARSİDER
:oops: Seems like I have pressed a ' at the wrong location ,haven't I? :oops:
Or maybe it is a lower case i, either way, it is wrong.

I will fix this as soon as possible, give me a couple of days at the most. I have fixed a few other bugs as weel so I have another update up my sleeve. Seems not many players at Starsider have used SWGAide, or they have given up without notifying me on this error :?

/Zimoon

User avatar
Zimoon
Forum Moderator
Posts: 4817
Joined: Mon May 14, 2007 6:55 am
Location: Stockholm, SE
Contact:

Re: cant install swgaide

Post by Zimoon » Tue Aug 10, 2010 11:40 am

Would you mind open a Command Prompt and type the following and copy and paste the output in your reply

C:\...> java -version

In another thread it was reported that the latest version of Java for Windows 7 at 64-bit machines is somewhat broken. I have not heard exactly what the problem is, but it if this is it it is sad. The latest version should read something such as build 1.6.0_21-b07) or the similar.

/Zimoon

User avatar
Zimoon
Forum Moderator
Posts: 4817
Joined: Mon May 14, 2007 6:55 am
Location: Stockholm, SE
Contact:

Re: cant install swgaide

Post by Zimoon » Tue Aug 10, 2010 11:58 am

What language do yo have for your Windows installation?

I just checked the code in SWGAide and it seems valid so I am wondering how the galaxy name reads in the SWG\profiles\station\GALAXY_NAME, could you have a look and verify that it really reads Starsider without any fancy stuff for the "i". You could post it here at your reply and I will see how it looks like in my character encoding. That is why I am interested in your language of Windows, could it possible be Turkish? :?:

User avatar
Zimoon
Forum Moderator
Posts: 4817
Joined: Mon May 14, 2007 6:55 am
Location: Stockholm, SE
Contact:

Re: cant install swgaide

Post by Zimoon » Tue Aug 10, 2010 1:45 pm

Error is fixed and I will upload a new version of SWGAide within a few days.

It seems this is an issue with the Turkish (I figured that you are from there, right?) "locale" which makes i to-upper-case become Í or the similar, which is not I. I have fixed SWGAide to ignore the "locale" in this case and use the correct upper case. This is not your fault nor anything with Turkish, it is just an anomaly a poor programmer have to live with 8)

Eğlenmek

Zimoon

sikocbrayt
Novice Crafter
Posts: 3
Joined: Sat Feb 06, 2010 10:36 pm

Re: cant install swgaide

Post by sikocbrayt » Wed Aug 11, 2010 6:34 am

java version

java version "1.6.0_21"
Java(TM) SE Runtime Environment (build 1.6.0_21-b07)
Java HotSpot(TM) Client VM (build 17.0-b17, mixed mode, sharing)

my system is windows xp sp3 english, im just using turkish keyboard lol :) i have tried changing local settings nothing different same error.

User avatar
Zimoon
Forum Moderator
Posts: 4817
Joined: Mon May 14, 2007 6:55 am
Location: Stockholm, SE
Contact:

Re: cant install swgaide

Post by Zimoon » Wed Aug 11, 2010 12:17 pm

Yes, the dotted capital Ì is a Turkish thing only ;)
Next update of Simics fixes this, I have replaces all to-upper-case and to-lower-case to always use a save "locale".

/Zimoon

sikocbrayt
Novice Crafter
Posts: 3
Joined: Sat Feb 06, 2010 10:36 pm

Re: cant install swgaide

Post by sikocbrayt » Wed Aug 11, 2010 1:54 pm

cool, thanx a lot.


this locale problem will always exist i think. havent seen a proper solution. last year i was workin on a web-based crm automation, the company has branches in ukraine, russia, turkey and bulgaria.it was a painful. you cant work on the project cos of debugging the locale bugs. i hated the languages people spoke, wished all people speak the same language lol.

User avatar
Zimoon
Forum Moderator
Posts: 4817
Joined: Mon May 14, 2007 6:55 am
Location: Stockholm, SE
Contact:

Re: cant install swgaide

Post by Zimoon » Wed Aug 11, 2010 2:08 pm

sikocbrayt wrote:cool, thanx a lot.


this locale problem will always exist i think. havent seen a proper solution. last year i was workin on a web-based crm automation, the company has branches in ukraine, russia, turkey and bulgaria.it was a painful. you cant work on the project cos of debugging the locale bugs. i hated the languages people spoke, wished all people speak the same language lol.
:)

Post Reply

Who is online

Users browsing this forum: Magpie [Bot] and 4 guests