Inventory Bug in 0.8.11

Moderator: Forum Moderator

Post Reply
Novice Crafter
Posts: 1
Joined: Wed Jul 07, 2010 1:22 pm

Inventory Bug in 0.8.11

Post by darkk » Wed Jul 07, 2010 1:26 pm


I've found a small bug in swgaide.

Basically when you've added a recycled resource to your inventory, for
the next resource you try to lookup and add, the resource class dropdown
list is never filled after lookup. And you can't add to inventory then.
It can be worked around by checking and unchecking the "recycled"
checkbox again.

Reproduction steps:

0. go to Resources -> Inventory

1. right click main screen

2. use "create" menu item

3. select "recycled" checkbox

4. select a recycled resource type. I've tried and reproduced with
synthesized hide
ground bones
blended wood

5. click "OK" button

6. right click main screen

7. use "create" menu item

8. enter a resource name to lookup, i've tried and reproduced with

result: while the stats are filled into the related text fields, the
dropdown box is never filled with the class of the resource. If you
click add, nothing happens.

check and uncheck "recycled" checkbox and start over with step 8.

hope that helps!


Forum Moderator
Posts: 4817
Joined: Mon May 14, 2007 6:55 am
Location: Stockholm, SE

Re: Inventory Bug in 0.8.11

Post by Zimoon » Wed Jul 07, 2010 3:20 pm

Thanks Darkk,

Amazing, this is one of the top 3 best written bugs ever. Triple gold-stars in wire transfer as I speak ;)

I tried this in SWGAide and also read an error in the error-log file, but it turns out that just that log would not have helped me much whatsoever because it was the previous step that caused a special situation that the log does not tell, you had created an entry for a recycled resource. Because of a tiny mistake on my side that left the dialog in a "recycled resource" state.

Again, your report is flawless and deserves my praise :)

Problem fixed and is included in the next update. Your workaround does work, toggle the check-box twice.


Post Reply

Who is online

Users browsing this forum: No registered users and 6 guests