Page 1 of 1

Delete Schematic Problem

Posted: Thu May 14, 2009 8:36 am
by Akshaag
Hi,

It's seems they are a problem when you want to delete a schematic. I explain, i would like to edit 'starshine surprise' schematic and i realized that the schematic was already created with an id of 411. So, i updated 'resources' to nothing (blank), 'components' to nothing (blank) and finaly 'Skill Needed' to nothing (blank). So, after the erase of 'Skill Needed', the schematic completely disappeared form swgcraft website as a delete but when you download the file 'schem.xml', you could verify that the 'starshine surprise' is always there with an id of 411 (good) and an id of 1691 (WRONG). So i guess that the schematic is always in your database and i think there are a problem when you try to put to blank a schematic. There another schematic called 'DELETE ME' always in the database with id 1688 but not displayed in the website.

I hope to be understood well :-) If you could verify by your self ;-)

Thank you

Re: Delete Schematic Problem

Posted: Thu May 14, 2009 12:46 pm
by Sobuno
Schematic Maintainers cannot delete schematics, only edit and create new ones. If you find a schematic that needs deletion, please rename it to something starting with Delete ("Delete me", "Delete this", "Delete" etc.) and post about it here so an admin can delete it from the database. You do not need to delete the resources, components, experimentation lines etc. as the admin will take care of that.

Regarding the schem.xml file, it is not generated upon each request, but is, as far as I recall, generated twice a week. The schematics will appear in that file, even if it is not associated with a level. The only ways for a schematic to not appear in that file is if an admin has deleted the schematic or if the schematic has been set to be invisible (Can also only be done by admins, used for the testing schematics).

Thanks for trying though, I have deleted the two schematics you mentioned (1691 and 1688)

Re: Delete Schematic Problem

Posted: Sun May 17, 2009 12:35 am
by Zimoon
Moved to the schematicsĀ“ forum board. Here you also find a "guide" on how to maintain schematics, enjoy :)

/Zimoon

Re: Delete Schematic Problem

Posted: Mon Jan 18, 2010 12:05 pm
by Zimoon
Testing schematics in SWGAide

It seems as schematic #1793 can be deleted :)

Otherwise everything looks nice this far.

/Zim

Re: Delete Schematic Problem

Posted: Tue Jan 19, 2010 11:59 pm
by Sobuno
Zimoon wrote:Testing schematics in SWGAide

It seems as schematic #1793 can be deleted :)

Otherwise everything looks nice this far.

/Zim
Done

Re: Delete Schematic Problem

Posted: Mon Jan 25, 2010 2:04 pm
by Zimoon
I was testing schematics while updating the guide for schematics maintainers, please delete
schem=1799

/Zimoon